
Lecture Note #2: Extra Options in Excel

BUSI 201: Business Data Analysis

Topic 1. Auto Recovery Options

While the occurrence of sudden power loss resulting in the loss of hours of work is becoming rarer
due to the prevalence of laptops with battery backup, it’s still a possible scenario. It’s wise to configure
Excel to automatically save your progress to mitigate this risk. To set this up, follow these steps: navigate
to File > Options > Save. This will lead you to a window resembling the one shown in Figure 1.

The default autosave frequency is typically set at 10 minutes, and the minimum interval is 1 minute.
Frequent saving ensures that you lose minimal work in the event of an unexpected event. However, it
might also lead to performance issues if your device is older, the spreadsheet contains extensive data, or
numerous functions are being utilized. This setting depends on your preferences and tolerance for risk.

Figure 1: AutoRecovery Options

After configuring this setting, your spreadsheetwill be automatically saved everyN minutes to the file
location specified in AutoRecover file location. However, if this file is relatively new and hasn’t
been manually saved at least once, it might be stored in a temporary Unsaved folder. To recover docu-
ments from the Unsaved folder, follow these steps: navigate to File > Open > Recent. There you
will find the Recover Unsaved Workbooks button.
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Figure 2: UnsavedWorkbooks

Topic 2. Find and Replace

Figure 3: Find and replace

Find and Replace Values

The more information each worksheet contains, it becomes increasingly difficult to locate cells con-
taining specific information. We will learn of more efficient methods later in the semester, but for now
we will explore another powerful tool, Find and Replace. To access this function, navigate to Home

> Find&Select > Replace. If you are on PC, you can also use the hotkey crtl+H.
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Figure 4: Finding Amazon Basic

Please open the 2023Q3Stock sheet
in BUSI201-LEC02-Workbook.xlsx.
We will now attempt to locate all oc-
currences of Amazon Basics on this
specific worksheet. You can achieve
this by using the ”Find and Replace”
tool, typing Amazon Basics next to
“Find what,” and clicking on “Find All.”
As shown in Figure 4, all instances of
Amazon Basics will be listed in the
“Find and Replace” window.

By clicking on the items in the “Find
and Replace” window, you can navi-
gate between each occurrence of Amazon
Basics. I encourage you to try this with
other items as well.

Figure 5: Replacing Amazon Basic to Amazon

Now, let’s say we want to change
Amazon Basics to the more concise
term Amazon. In this specific example,
this task is simple since we only have three
instances to change. However, for a large
dataset, manually finding and changing
each occurrence would become a tedious
process. Thankfully, the “Find and Re-
place” function can help us accomplish
this task efficiently.

In this particular case, you can input
Amazon Basics next to “Find what,”
and Amazon in the “Replace with” field.
Afterward, click on “Replace All.” Excel
will then display a notification similar to
Figure 5, indicating that all three instances
of Amazon Basics have been changed
to Amazon.

One word of caution before we move on to our next topic: you should never press “Replace All”
prematurely. As you may have observed in Figure 5, Excel doesn’t provide details about which cells it
changes; it only confirms that it carried out the command. The best practice is to initially click on “Find
All,” review the list to ensure that Excel is only targeting the items you intend to change, and then proceed
with “Replace All.”
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Find and Replace Options

Figure 6: Replacing Across Sheets

In the previous example, we explored
how to find and replace specific val-
ues within a given worksheet. How-
ever, if we want to replace instances of
Amazon Basics with Amazon not only
for 2023Q3 but also for all other quar-
ters, we need to adjust the value in the
“Within” field to Workbook. By chang-
ing the search scope from the individ-
ual worksheet to the entire workbook,
we can update all occurrences of Amazon
Basics to Amazon.

Additionally, there are other options
worth considering, such as the “Match
Case” and “Match Entire Cell Contents”
options.

Find and Replace Formats

This “Find and Replace” function also provides the capability to select cells that share a specific for-
mat, such as font, font size, or cell color, and replace it with a new format. Let’s consider the worksheet
2023Q3Stock in the workbook BUSI201-S2024-LEC02-Workbook.xlsx. Imagine that you wish to
change the cell color of the row containing variable names in the sheet 2023Q3Stock to dark gray instead
of black.

Figure 7: Selecting the cells to change Figure 8: Target format
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Open the “Find and Replace” window tomatch the setup shown in Figure 7. Then, choose Choose
format from Cell and select the cells you want to modify. Afterward, select the replacement format,
as illustrated in Figure 8. In this instance, we’re altering the cell background color; however, you have
the ability tomodify various formats such as font, font size, cell number format, alignment, borders, and
more.

Topic 3. Autofill

Excel’s autofill function operates by analyzing the data to identify any existing patterns and then ap-
plying that pattern to automatically populate empty cells. Please open the Autofill sheet in the work-
book BUSI201-S2024-LEC02-Workbook.xlsx to practice. Below is a brief summary of some of the rules
that Excel follows when autofilling cells:

Select Single Cell Select Multiple Cells
Drag Drag + ctrl Drag Drag + ctrl

Text Repeat Same Value(s)
Number Repeat Value Increasing by 1 Recognize Pattern Repeat Selected Values
Date Increasing by 1 day Repeat Same Value Recognize Pattern Repeat Selected Values
Time Increasing by 1 hour Repeat Same Value Recognize Pattern Repeat Selected Values

Text + Number Last Number Increases by 1 Repeat Same Value Recognize Pattern Repeat Selected Values

After autofilling a section of the spreadsheet, you should have the opportunity to review certain aut-
ofill options that were applied during the process. This option will appear, as shown in Figures 9 and
10. The specific options presentedmay vary depending on the type (format) of data that Excel autofilled.
Figure 10 illustrates the options presented when the autofilled cells are recognized as dates.

Figure 9: Accessing autofill options Figure 10: Example of autofill options
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Custom Lists

While Excel provides a range of useful autofill patterns, there may be instances where you frequently
use certain custom patterns. For example, imagine you regularly create weekly incident reports detailing
accidents or consumer complaints. In such cases, youmightwant Excel to automatically populate certain
cells as part of your report.

Figure 11: Navigate to custom lists

To achieve this goal, navigate to File > Options > Advanced. Scroll down until you locate
Edit Custom Lists. Here, you can add your own custom list thatwill be available for future autofills.
Figure 12 demonstrates the application of a custom list.

Figure 12: Applying custom lists
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Topic 4. Flash Fill

Flash Fill is an Excel function that bears some similarity to autofill, as it offers user convenience by
attempting to recognize patterns in existingdata and automatically filling out certain cells. Topractice this
feature, please open theFlash Fill sheet in theworkbookBUSI201-LEC02-Workbook.xlsx, which
contains a list of the Business and Economics faculty atMonmouth College. Let’s say we want to extract
information like first and last names, login IDs, office numbers, and phone extensions. A straightforward
method to achieve this is through a variation of autofill, known as flash fill.

Figure 13: Flash fill setup

To initiate flash fill, you first need to manually fill out the (at least the) first row. Excel will utilize this
information to deduce the pattern it should apply to fill out the remaining rows. Once the first row is
completed, select a cell directly below the first row and use the hotkey ctrl+E. In Figure 14, you can
observe that flash fill effectively extracts the first names.

Figure 14: Flash filled second row
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Topic 5. Status Bar

The status bar is situated at the bottom of your spreadsheet, as depicted in Figure 15. When you
select a range of numerical data, the status bar provides you with three default statistics for your selected
numbers: the average, the count, and the sum.

Figure 15: Status bar

Mistakes are all too common when dealing with data and tables, and having quick calculations pro-
vided in real-time could prove incredibly useful. That being said, if you’re dealing with a large amount of
information, it’s a better idea to rely on functions or pivot tables. However, using the status bar can be
far more convenient when the dataset is small.

Figure 16: Text Only Figure 17: Numbers Only
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Please open the 2023Q3Stock sheet of the BUSI201-S2024-LEC02-Workbook.xlsxworkbook.
When you select a region containing text data, only the count information is returned, indicating the
number of items in the given region. Try this by selecting cells B5:B16, as shown in Figure 16. To do this,
left-click on cell B5, then drag the mouse cursor while holding down the left mouse button to cell B16,
and finally release the left mouse button.

On the other hand, if you select a region with numerical data, the status bar will display three values.
First is the count: the number of items included in the region. Second is the average value of the numbers
in the selected region. Third is the sum of all values included in the region. Experiment with this by
selecting cells H5:H16, as shown in Figure 19.

If you choose a mixture of text and numbers, the status bar will show you the average and sum of the
numbers, but it will display the count of all cells containing any type of data. Hence, exercise caution
when interpreting the numbers provided by the status bar.1

Adding Min / Max to the Status Bar

In practice, the average, count, and sum are all significant statistics. Nevertheless, you often need to
determine the minimum and maximum values across all cells. These statistics can also be added to the
status bar. Right-clicking on the status bar will bring up the menu depicted in Figure 18. After selecting
Minimum and Maximum, you will notice that these two values now appear on the status bar alongside the
default count, sum, and average values.

Figure 18: Adding items to status bar Figure 19: New items in status bar

1There is a workaround where you can add a “numerical count” that reports the count of numerical items.
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Topic 6. Hotkeys

The following is a nonexhaustive list of some hotkeys that are frequently used in Excel:

• ctrl+Arrow Keys: Move to the “End”

• shift+Arrow Keys: Start Selecting a Region

• ctrl+shift+Arrow Keys: Select to the “End”

• ctrl+Z: Undo

• ctrl+Y: Redo

• ctrl+C: Copy

• ctrl+V: Paste

• ctrl+alt+V: Paste (with Options)

• ctrl+S: Save

• ctrl+A: Select “All”

• ctrl+N: Create NewDocument

• shift+F11: Create New Sheet

• ctrl+pageup: Move to Previous Sheet

• ctrl+pagedown: Move to Next Sheet

• ctrl+Mouse Wheel: Zoom In / Out

• elt+enter: Line Break within Cell

• ctrl+F: Find

• ctrl+H: Find and Replace

• ctrl+D: Autofill with Content Above

• ctrl+R: Autofill with Content to the Left

• ctrl+E: Flash Fill

• ctrl++: Call “Insert” Menu

• ctrl+-: Call “Delete” Menu

• F2: Edit Selected Cell

• F4: Repeat Previous Task
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Topic 7. Custom Hotkeys

oumight frequently need to use a set of characters that aren’t readily available on a standard keyboard.
For example, arrows, Roman numerals, bullet points, and the like. It would be inefficient to navigate
through a character map each time you need one of these symbols. That’s why you can establish an
autocorrect function. To set this up, go to File > Proofing > AutoCorrect Options.

Figure 20: Using Autocorrect as a Hotkey

Here, you have the option to establish a custom shortcut by adding an autocorrect rule. For example,
if we follow the settings shown in Figure 20, entering (smile)will automatically be corrected to,. Ad-
ditionally, you might find yourself frequently using specific functions that lack default hotkeys. In such
cases, you can create your own “hotkey.”Todo this, navigate to Customize Quick Access Toolbar

> More Commands on the top of the window.

Figure 21: Creating CustomHotkeys
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Afterward, you should be able to bring up the following window. Locate a function that you would
like to have readily accessible and add it to the Quick Access Toolbar. As an illustration, in this case, I am
adding the Merge&Center function.

Figure 22: Creating CustomHotkeys

Youwill see that theMerge&Center key is now located in the top left corner of thewindow. Holding
alt shows you which key to press to access the newly added function. Under this setup, we can access
the Merge&Center key by pressing alt→5.

Figure 23: Using CustomHotkeys
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Topic 8. Errors

Before we begin discussing functions, let’s take some time to understand some of the common errors
you may encounter. We’ll start by addressing some of the more straightforward error messages. The first
two are not actually “errors.”

Error Message Cause Solution

########## Column width insufficient to
display numerical data. Adjust column width.

1E+11 Numerical value too large to
express directly. (Exceeds 10ˆ11) Adjust format of cell.

#NAME? Function name (or function’s
domain) is incorrect.

Double check the function’s
name or domain.

#N/A Reference function could
not locate items.

Double check the
function and range.

#VALUE! Items in the function’s
domain is incompatible.

Double check the
function’s domain.

#REF! The function is referencing cells
that have been removed. Adjust function’s domain.

#DIV/0 Dividing a number by 0
or an empty cell. Adjust function’s domain.

“Covert” Errors: Green Triangles

It’s relatively easy to notice when an error has been detected in your worksheet due to the presence
of an error message. However, there are instances where Excel will display a green triangle in the top-left
corner of a cell. This triangle indicates that Excel “suspects” you may have made an error. The four cases
listed below are the most common cases you will encounter.

• Function returns an error.

• Some cells (that Excel thinks should be included) are left out.

• Numerical values are stored as text.

• Formulae are not consistent with adjacent cells.
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Resolving Green Triangle Errors

Let’s walk through an example of how these green triangle errors are reported and can be resolved.
Please open sheet Error 1 in BUSI201-S2024-LEC02-Workbook.xlsx. The table is designed to
track photo equipment within a hypothetical company. As depicted in figure 24, there is a green triangle
present in cell G17, which is intended to display the total value of all items stored.

Figure 24: Green Triangle

If you hover the mouse cursor over the box with an exclamation mark in it, an error message “The
formula in this cell refers to a range that has additional numbers adjacent to it.” is revealed. This means
that there is at least one number that has been left out in calculating the sum.

Figure 25: The SUM function

The function used in this cell is the
SUM function, which returns the sum of
all values included in the range. Notice
that the range is set as G3:G14, which
leaves out the value of the last item on the
list. You can correct this error by replacing
the range with G3:G15.

Another way to correct the error is
to click the “Update Formula to Include
Cells” option shown in Figure 24. You
can access this menu by left-clicking on
the box with the exclamation mark that
appears when you select cell G17. I would
advise you to check if theupdated formula
indeed reflects your intentions, as there is
no guarantee that what Excel thinks is cor-
rect is what the user intended.
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Correcting Multiple Green Triangle Errors

You may also encounter cases where there are multiple green triangle errors in a single worksheet. In
such cases, correcting one error at a timewould be an inefficient use of your time. Let’s walk through one
more example with a different type of error to learn how to deal with multiple errors of the same type.
Please open the sheet Error 2 in the file named BUSI201-S2024-LEC02-Workbook.xlsx.

Figure 26: Green Triangles

The error in this specific case is that some numbers are stored as text, rather than being stored as
numbers. This can be achieved when you insert an apostrophe in front of a number. We can see that this
is causing the SUM function to not work as intended in column I.

Figure 27: Numbers as Texts

To correct this error, we first select
the range C3:H20which are the cells that
share a common error. Then, click on the
box with the exclamation mark, and then
click “Convert to number” to correct the
error.

After the error has been corrected,
you can immediately notice that the SUM
function now works as intended, display-
ing the total number of each appliance
sold between the months of Jan∼Jun. If
you navigate to each cell that once dis-
played the green triangle error, you can see
that the apostrophe has been removed.
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Ignoring Green Triangles: NOT Recommended

From time to time, youmay encounter cases where Excel thinks that something you did intentionally
was, in fact, an error. For instance, youmay intentionally want to leave out one row’s worth of data when
calculating a sum, as it includes information about expenses that are not reimbursable. In this scenario,
Excel will still think you made an error by excluding one row. You may choose to leave the green triangle
alone, but you do have an option to ignore these errors.

Figure 28: Ignoring Errors

Navigate to File > Options > Formulas. Under “ErrorChecking,” you can disable background
error checking completely by deselecting ‘Enable background error checking.” You may also customize
the rules that Excel applies when determining if a cell contains an error. You can do this by selecting or
deselecting items under “Error checking rules.”

Checking for Errors Manually

Figure 29: Numbers as Texts

If you come across a situationwhere youwant to
manually prompt Excel to check for errors, you can
navigate to Formulas > Error Checking. The
icon should look like a yellow triangle with an excla-
mation mark embedded inside.

The error checking window will show you if
there are any suspected errors, the location of the er-
ror, and give you a choice to either fix the error auto-
matically or ignore the error.
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